1 / 54
文档名称:

杭电题目acm部分答案.doc

格式:doc   大小:230KB   页数:54页
下载后只包含 1 个 DOC 格式的文档,没有任何的图纸或源代码,查看文件列表

如果您已付费下载过本站文档,您可以点这里二次下载

分享

预览

杭电题目acm部分答案.doc

上传人:allap 2018/3/29 文件大小:230 KB

下载得到文件列表

杭电题目acm部分答案.doc

文档介绍

文档介绍:1001 Sum Problem 2
1089 A+B for Input-Output Practice (I) 4
1090 A+B for Input-Output Practice (II) 6
1091 A+B for Input-Output Practice (III) 8
1092 A+B for Input-Output Practice (IV) 9
1093 A+B for Input-Output Practice (V) 11
1094 A+B for Input-Output Practice (VI) 12
1095 A+B for Input-Output Practice (VII) 13
1096 A+B for Input-Output Practice (VIII) 14
2000 ASCII码排序 16
2001计算两点间的距离 17
2002计算球体积 19
2003求绝对值 20
2004成绩转换 21
2005第几天? 22
2006求奇数的乘积 24
2007平方和与立方和 26
2008数值统计 27
2009求数列的和 28
2010水仙花数 29
2011多项式求和 31
2012素数判定 33
2014青年歌手大奖赛_评委会打分 34
2015偶数求和 36
2016数据的交换输出 38
2017字符串统计 40
2019数列有序! 41
2020绝对值排序 43
2021发工资咯:) 45
2033人见人爱A+B 46
2039三角形 48
2040亲和数 49
1001 Sum Problem
Problem Description
Hey, e to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1
100
 
Sample Output
1
5050
 
Author
DOOM III
解答:
#include<>
main()
{
int n,i,sum;
sum=0;
while((scanf("%d",&n)!=-1))
{
sum=0;
for(i=0;i<=n;i++)
sum+=i;
printf("%d\n\n",sum);
}
}
1089 A+B for Input-Output Practice (I)
Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
 
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
 
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 
Sample Input
1 5
10 20
 
Sample Output
6
30
 
Author